Generalchevron_right Browser and video Supportchevron_right

Troubleshooting Video Performance

"No playable sources found" error message

If you receive this error, please see the following articles:
Video Playback on Linux
Video Playback on Windows 7

The appearance of buffering when refreshing in Chrome

Chrome enforces rules that determine whether or not a video can autoplay on page load. Chrome may prevent a video from automatic playback, and this may cause the buffering icon to show in the video player.  As a workaround, you can pause and play the video, playback will then start.  Once Chrome "trusts" the Linux Academy website, this issue will no longer occur.  We are currently looking into solutions for this issue.

Other issues including "Cannot load M3U8: Cross-domain access denied (2048)" error message

Typically this error will be associated with your browser, network, or device. If you receive this error, please try the following steps:

  1. Clear your browser cache, log out, close your browser, and then log back in and retry the video(s) that had issues.
  2. Try running your browser in 'Incognito' mode. This can sometimes disable 3rd party browser extensions that can cause performance issues.
  3. Disable any VPN or proxy network connection
  4. Try from a different network location (if at work, try from home for example)
  5. Change to Google's Public DNS Servers (8.8.8.8 and 8.8.4.4), this will force your connection down a different path.
  6. Reboot your computer.
  7. Check for any available updates for your computer and reboot again.
     

If you have followed all of the above steps and continue to experience issues with the video performance, please email support@linuxacademy.com