Generalchevron_right Browser and video Supportchevron_right

What web browsers do you support?

At this time, the only minimum requirements needed to access our platform are a modern web browser with a network connection that can support video streaming. The current list of supported browsers includes, but is not limited to the following:

  • Google Chrome
  • FireFox
  • Brave
  • Opera
  • Chromium
  • Edge
  • Internet Explorer 11
  • Safari

In an effort to increase the overall security of our platform, we will be updating our security standards to require TLS 1.2. This change will go into effect on February 17th, 2020. 

As long as your browser is up to date and accepts TLS 1.2, you should not be impacted.The connection however, will be refused if TLS 1.2 support is disabled, or your browser is out of date. 

If you have any questions, feel free to reach out to our Support team at support@linuxacademy.com